Upgrading to WordPress 2.9 failed


Warning: file_get_contents(): php_network_getaddresses: getaddrinfo failed: Name or service not known in /homepages/15/d336520767/htdocs/ddrinfo/past/wp-content/plugins/tk-social-share/tk-social-counter.php on line 88

Warning: file_get_contents(http://urls.api.twitter.com/1/urls/count.json?url=http://deardanielim.info/past/upgrading-to-wordpress-2-9-fail.ddr): failed to open stream: php_network_getaddresses: getaddrinfo failed: Name or service not known in /homepages/15/d336520767/htdocs/ddrinfo/past/wp-content/plugins/tk-social-share/tk-social-counter.php on line 88

Warning: file_get_contents(http://www.linkedin.com/countserv/count/share?url=http://deardanielim.info/past/upgrading-to-wordpress-2-9-fail.ddr&format=json): failed to open stream: HTTP request failed! HTTP/1.0 404 Not Found in /homepages/15/d336520767/htdocs/ddrinfo/past/wp-content/plugins/tk-social-share/tk-social-counter.php on line 140

Upgrading to wordpress 2.9 failed. Downgrading again back to wordpress 2.8; maybe it is caused by php 4.9?